Bode Plot Probe w/ Measurements

The Bode Plot Probe w/ Measurements generates plots for the gain and phase of the ratio of two voltages. The probe cab be configured to plot only the gain or phase, or both gain and phase.

In this topic:

Model Name: Bode Plot Probe
Simulator: This device is compatible with both SIMetrix and SIMPLIS simulators
Schematic Menu Location: Probe AC/Noise > Bode Plot Probe - with Measurements
Parts Selector Menu Location: Probes > Bode Plot Probe (Gain/Phase) w/ Measurements
Symbol Library: Connections
Model File: none
Multiple Selections: If multiple Bode plot probes are selected before editing, all properties except the curve labels can be simultaneously changed for all probes. The curve label properties will remain unchanged for all selected probes.
Usage: This schematic probe symbol plots the magnitude and phase of the ratio of two complex voltages, OUT/IN. The magnitude can be plotted in db or volts/volts; the horizontal axis scale is determined by the simulation sweep type. If the simulation is swept in log frequency steps, the horizontal axis will automatically be log scaled.

Editing the Bode Plot Probe w/ Measurements

To configure the Bode Plot Probe w/ Measurements, follow these steps:

  1. Double click the symbol on the schematic to open the editing dialog to the Parameters tab.
  2. Make the appropriate changes to the fields described in the table below the image.
Label Description
Use separate graph Check this option in order to supply an alias for each output graph tab.
Graph name The Graph name is an alias for each output graph tab and will not be visible on the graph output. Curves with the same graph name property will be output on the same graph tab. Graph name be safely ignored unless multiple Bode plot probes are used. Use separate graph must be checked to supply this name.
Disable gain/phase Check this box to disable both gain and phase graphs
Persistence The Persistence property determines when previous simulation data is deleted from the graph viewer. If Use default is checked or if the persistence is set to -1, the probe uses the default global persistence value.

The default persistence can be set from the command shell menu: File > Options > SIMPLIS Options....

  • If set to "0", the graph data is never deleted, and subsequent simulations will add new curves to the same axis locations.
  • If set to a positive integer, the persistence value will be interpreted as the number of simulations to keep on the graph. For example, a persistence setting equal to 1 keeps only the current data, and each subsequent simulation overwrites the graph. A setting equal to 2 keeps the current data and the data from the previous simulation.
Curve label Sets the name of the curve.
Note: This field appears in both the Gain and Phase groups on the dialog.
Y axis label Sets the Y axis label for the individual gain and phase axes. When multiple curves from multiple probes are placed on the same axis, the axis label properties must be identical or the axis label is blank. If this field is left blank, the axis label appears with the name specified in the Curve label field.
Note: This field appears in both the Gain and Phase groups on the dialog.
Vertical scale Allows you to select the function to perform on the simulation data.
  • Select db to perform the built-in db() vector function.
  • Select the mag radio button to perform the mag() function.
Curve Selects the Phase curve offset
  • Select Phase for no offset.
  • Select Phase - 180 degrees to subtract 180 degrees before plotting the curve.
Vertical axis This group has two options:
Vertical limits:
  • Check to have the vertical limits automatically set to fit the curve data.
  • Uncheck to enter minimum and maximum values  for the limits.

Both minimum and maximum axis limits must be set or auto-calculated as a group.

Grid spacing:
  • Check to auto calculate the grid spacing.
  • Uncheck to set the grid spacing independent of the axis limits
Note: This field appears in both the Gain and Phase groups on the dialog.
Colour Defines colors for the curves:
  • Check Use default in both the Gain and Phase groups o generate the curves  with the same default colour, which is automatically selected from a sequence of colours.
  • Leave Use default unchecked and click Edit... to open a colour selector dialog box to specify fixed colours for the curves.

The change the default sequence of colours from the command shell menu, select File > Options > SIMPLIS Options...

For additional information, see Colours and Fonts.

Note: This field appears in both the Gain and Phase groups on the dialog.  
Display curves on Allows you to define the number of grids in the output: Single grid or Two grids.
Vertical order Allows you to specify the order of the curves: Phase above Gain or Gain above Phase.
  • If you selected Two grids is in the Display curves on group, the selection in this group specifies the curve output location.
  • If you selected Single grid, both curves are on the lower grid with two axes.
Example curve output: Example curve output illustrates the relative locations of the two curves.
Note:  The curve data here is fixed; these curves are examples and do not reflect the simulated curves.
Save Configuration Click Save Configuration to preserve this information as the default configuration for all future new Bode plot probes.

Symbol Migration

Symbols placed on schematics in previous versions of SIMetrix/SIMPLIS can be automatically migrated to use the new symbols. The schematic tools menu Tools > Migrate Schematic Symbols to Version 8.00 will invoke a routine which migrates the existing symbols to the new symbols. As this action makes substantial changes to the schematic, it is recommended that you save a backup copy of the schematic first.